Major security fix in Joomla! version 3.4.5

A new Joomla! security vulnerability was officially announced by the Joomla Security Strike Team (JSST). It is affecting a large number of Joomla users and can easily allow full access to your website and disclosure of all the information in your database. Our recent investigation shows that one-third of the Joomla! users are affected by the security vulnerability and an immediate update is required to protect your website.

Affected Versions

The affected Joomla! versions are between 3.0 and 3.4.4. The Joomla! 3.4.5 is important as it provides a security fix that will ensure your website is protected.

Vulnerability Fix

On the 22nd of October, the Joomla! project released the Joomla! 3.4.5 release, which provides a security fix that will keep your website protected. Just 90 minutes after the announcement, third-party projects started publishing information on how to exploit the vulnerability and gain access to Joomla! websites. A very dangerous situation that requires immediate attention.

FastComet recommend that all Joomla! users start updating their websites in order to avoid any issues. We have already sent out a notification to all Joomla! clients to make sure they stay protected. If you have missed that for some reason, you can easily log into your and contact our technical support. We will be happy to assist you with the upgrade of your website to Joomla! 3.4.5.

Daniel

Daniel is Director of Technical Support at FastComet. He has dedicated more than ten years toward bridging gaps between customer satisfaction and technical support. As the leader of our support organization, he’s responsible for educating, empowering and recognizing our support team and focusing on the science and art of quality, productivity, and technical prowess. He likes to be challenged with the tasks and do the research to approach the goal desired.